漏洞信息详情

global -parent 资源管理错误漏洞

  • CNNVD编号:CNNVD-202107-1558
  • 危害等级: 中危
  • CVE编号: CVE-2021-35065
  • 漏洞类型: 资源管理错误
  • 发布时间: 2021-07-21
  • 威胁类型: 远程
  • 更新时间: 2021-07-21
  • 厂        商:
  • 漏洞来源:

漏洞简介

Npm glob-parent是美国Npm公司的一个应用软件。从全局字符串中提取非魔术父路径。

global -parent存在资源管理错误漏洞,该漏洞的存在是由于应用程序在处理正则表达式时没有正确控制内部资源的消耗。远程攻击者可利用该漏洞可以触发资源耗尽并执行正则表达式拒绝服务(ReDoS)攻击。该漏洞允许远程攻击者可利用该漏洞执行拒绝服务(DoS)攻击。受影响的产品及版本如下:global -parent: 1.0.0、1.1.0、1.2.0、1.3.0、2.0.0、3.0.0、3.0.1、3.1.0、4.0.0、5.0.0、5.1.0、5.1.1、5.1.2、6.0.0

漏洞公告

目前厂商已发布升级补丁以修复漏洞,补丁获取链接:

https://www.cybersecurity-help.cz/vdb/SB2021072101

参考网址

来源:www.cybersecurity-help.cz

链接:https://www.cybersecurity-help.cz/vdb/SB2021072101

受影响实体

    暂无


漏洞信息快速查询

相关漏洞

更多