漏洞信息详情

Apache Eclipse 安全漏洞

  • CNNVD编号:CNNVD-202010-696
  • 危害等级: 高危
  • CVE编号: CVE-2019-17640
  • 漏洞类型: 其他
  • 发布时间: 2020-10-15
  • 威胁类型:
  • 更新时间: 2020-10-21
  • 厂        商:
  • 漏洞来源:

漏洞简介

Eclipse Vert.x是美国阿帕奇(Apache)软件基金会的一个应用于 JVM 上用于构建响应式应用程序的工具包。

Eclipse 存在安全漏洞,该漏洞源于在Windows操作系统上,StaticHandler不能正确处理反斜杠,从而允许将webroot文件夹转义到当前工作目录。以下产品及版本受到影响:Vert.x 3.4.x 版本至3.9.4版本, 4.0.0.milestone1版本, 4.0.0.milestone2版本, 4.0.0.milestone3版本, 4.0.0.milestone4版本, 4.0.0.milestone5版本, 4.0.0.Beta1版本, 4.0.0.Beta2版本, 4.0.0.Beta3版本。

漏洞公告

目前厂商已发布升级补丁以修复漏洞,补丁获取链接:

https://bugs.eclipse.org/bugs/show_bug.cgi?id=567416

参考网址

来源:CONFIRM

链接:https://bugs.eclipse.org/bugs/show_bug.cgi?id=567416

来源:nvd.nist.gov

链接:https://nvd.nist.gov/vuln/detail/CVE-2019-17640

受影响实体

    暂无


补丁

    暂无

漏洞信息快速查询

相关漏洞

更多