漏洞信息详情

Linux kernel 缓冲区错误漏洞

  • CNNVD编号:CNNVD-202003-1519
  • 危害等级: 高危
  • CVE编号: CVE-2020-10942
  • 漏洞类型: 缓冲区错误
  • 发布时间: 2020-03-24
  • 威胁类型: 本地
  • 更新时间: 2020-03-30
  • 厂        商:
  • 漏洞来源:

漏洞简介

Linux kernel是美国Linux基金会发布的开源操作系统Linux所使用的内核。

Linux kernel 5.5.8之前版本存在安全漏洞,该漏洞源于drivers/vhost/net.c文件的get_raw_socket没有验证sk_family字段。攻击者可借助特制的系统调用利用该漏洞造成内核栈损坏。

漏洞公告

目前厂商已发布升级补丁以修复漏洞,补丁获取链接:

https://git.kernel.org/pub/scm/linux/kernel/git/torvalds/linux.git/commit/?id=74ba569a15a08b988bc059ad515980f51e85be79

参考网址

来源:MISC

链接:https://lkml.org/lkml/2020/2/15/125

来源:MISC

链接:https://git.kernel.org/linus/42d84c8490f9f0931786f1623191fcab397c3d64

来源:MISC

链接:https://cdn.kernel.org/pub/linux/kernel/v5.x/ChangeLog-5.5.8

来源:nvd.nist.gov

链接:https://nvd.nist.gov/vuln/detail/CVE-2020-10942

来源:vigilance.fr

链接:https://vigilance.fr/vulnerability/Linux-kernel-memory-corruption-via-get-raw-socket-31876

受影响实体

    暂无


补丁

    暂无

漏洞信息快速查询

相关漏洞

更多