漏洞信息详情

rabbitmq-c 输入验证错误漏洞

漏洞简介

rabbitmq-c是一款基于C语言的AMQP(高级消息队列协议)客户端库。

rabbitmq-c 0.9.0版本中的amqp_connection.c文件的amqp_handle_input存在输入验证错误漏洞。该漏洞源于网络系统或产品未对输入的数据进行正确的验证。

漏洞公告

目前厂商已发布升级补丁以修复漏洞,补丁获取链接:

https://github.com/alanxz/rabbitmq-c/commit/fc85be7123050b91b054e45b91c78d3241a5047a

参考网址

来源:github.com

链接:https://github.com/alanxz/rabbitmq-c/blob/master/ChangeLog.md

来源:MISC

链接:https://news.ycombinator.com/item?id=21681976

来源:github.com

链接:https://github.com/alanxz/rabbitmq-c/commit/fc85be7123050b91b054e45b91c78d3241a5047a

来源:UBUNTU

链接:https://usn.ubuntu.com/4214-1/

来源:lists.debian.org

链接:https://lists.debian.org/debian-lts-announce/2019/12/msg00004.html

来源:usn.ubuntu.com

链接:https://usn.ubuntu.com/4214-2/

来源:www.auscert.org.au

链接:https://www.auscert.org.au/bulletins/ESB-2019.4583/

来源:nvd.nist.gov

链接:https://nvd.nist.gov/vuln/detail/CVE-2019-18609

来源:vigilance.fr

链接:https://vigilance.fr/vulnerability/RabbitMQ-C-Client-integer-overflow-via-amqp-handle-input-31073

来源:www.auscert.org.au

链接:https://www.auscert.org.au/bulletins/ESB-2019.4641/

来源:packetstormsecurity.com

链接:https://packetstormsecurity.com/files/155568/Ubuntu-Security-Notice-USN-4214-1.html

受影响实体

    暂无


漏洞信息快速查询

相关漏洞

更多