漏洞信息详情

Apache Thrift 缓冲区错误漏洞

  • CNNVD编号:CNNVD-201910-1680
  • 危害等级: 高危
  • CVE编号: CVE-2019-0210
  • 漏洞类型: 缓冲区错误
  • 发布时间: 2019-10-29
  • 威胁类型: 远程
  • 更新时间: 2019-12-06
  • 厂        商: Apache
  • 漏洞来源:

漏洞简介

Apache Thrift是美国阿帕奇(Apache)基金会的一个用于跨平台开发的框架。

Apache Thrift 0.9.3版本至0.12.0版本中存在缓冲区错误漏洞。该漏洞源于网络系统或产品在内存上执行操作时,未正确验证数据边界,导致向关联的其他内存位置上执行了错误的读写操作。攻击者可利用该漏洞导致缓冲区溢出或堆溢出等。

漏洞公告

目前厂商已发布升级补丁以修复漏洞,补丁获取链接:

http://mail-archives.apache.org/mod_mbox/thrift-dev/201910.mbox/<277A46CA87494176B1BBCF5D72624A2A%40HAGGIS>

参考网址

来源:mail-archives.apache.org

链接:http://mail-archives.apache.org/mod_mbox/thrift-dev/201910.mbox/%3C277A46CA87494176B1BBCF5D72624A2A%40HAGGIS%3E

来源:nvd.nist.gov

链接:https://nvd.nist.gov/vuln/detail/CVE-2019-0210

来源:www.ibm.com

链接:https://www.ibm.com/support/pages/node/1120701

漏洞信息快速查询

相关漏洞

更多