漏洞信息详情

LibRaw 安全漏洞

  • CNNVD编号:CNNVD-201812-307
  • 危害等级: 中危
  • CVE编号: CVE-2018-5807
  • 漏洞类型: 资料不足
  • 发布时间: 2018-12-10
  • 威胁类型: 远程
  • 更新时间: 2018-12-10
  • 厂        商: Libraw
  • 漏洞来源:

漏洞简介

LibRaw是LibRaw团队开发的一个用来处理RAW(CRW/CR2、NEF、RAF、DNG和others)格式图片的C++库。

LibRaw 0.18.9之前版本中的internal/dcraw_common.cpp文件的‘samsung_load_raw()’函数存在安全漏洞。远程攻击者可利用该漏洞造成拒绝服务(越界读取和崩溃)。

漏洞公告

目前厂商已发布升级补丁以修复漏洞,补丁获取链接:

https://github.com/LibRaw/LibRaw/blob/master/Changelog.txt

参考网址

来源:github.com

链接:https://github.com/LibRaw/LibRaw/blob/master/Changelog.txt

来源:github.com

链接:https://github.com/LibRaw/LibRaw/commit/fd6330292501983ac75fe4162275794b18445bd9

来源:secuniaresearch.flexerasoftware.com

链接:https://secuniaresearch.flexerasoftware.com/advisories/81800/

来源:secuniaresearch.flexerasoftware.com

链接:https://secuniaresearch.flexerasoftware.com/secunia_research/2018-10/

来源:usn.ubuntu.com

链接:https://usn.ubuntu.com/3838-1/

漏洞信息快速查询

相关漏洞

更多