漏洞信息详情

PHP 缓冲区错误漏洞

漏洞简介

PHP(PHP:Hypertext Preprocessor,PHP:超文本预处理器)是PHP Group和开放源代码社区共同维护的一种开源的通用计算机脚本语言。该语言主要用于Web开发,支持多种数据库及操作系统。

PHP中存在基于堆的缓冲区溢出漏洞。远程攻击者可通过发送特制的请求利用该漏洞在系统上执行任意代码。以下版本受到影响:PHP 5.6.37之前版本,7.0.31之前的7.0.x版本,7.1.20之前的7.1.x版本,7.2.8之前的7.2.x版本。

漏洞公告

目前厂商已发布升级补丁以修复漏洞,补丁获取链接:

http://php.net/ChangeLog-5.php

http://php.net/ChangeLog-7.php

参考网址

来源:php.net

链接:http://php.net/ChangeLog-5.php

来源:php.net

链接:http://php.net/ChangeLog-7.php

来源:bugs.php.net

链接:https://bugs.php.net/bug.php?id=76423 来源:NSFOCUS 名称:40671 链接:http://www.nsfocus.net/vulndb/40671

漏洞信息快速查询

相关漏洞

更多