漏洞信息详情

mruby 堆缓冲区错误漏洞

漏洞简介

mruby是一个Ruby语言的轻量级实现。

mruby 1.4.1版本中存在堆缓冲区溢出漏洞,该漏洞源于在大量参数传递到fiber时,mrbgems/mruby-fiber/src/fiber.c文件没有扩展栈的空间。攻击者可利用该漏洞造成越界读取。

漏洞公告

目前厂商已发布升级补丁以修复漏洞,补丁获取链接:

https://github.com/mruby/mruby/commit/778500563a9f7ceba996937dc886bd8cde29b42b

参考网址

来源:github.com

链接:https://github.com/mruby/mruby/commit/778500563a9f7ceba996937dc886bd8cde29b42b

来源:github.com

链接:https://github.com/mruby/mruby/issues/4038

受影响实体

    暂无


补丁

    暂无

漏洞信息快速查询

相关漏洞

更多