【漏洞预警】CNNVD关于泛微E-cology OA系统远程代码执行漏洞情况的通报

发布时间:2019-09-23   

       近日,国家信息安全漏洞库(CNNVD)收到关于泛微E-cology OA系统远程代码执行漏洞(CNNVD-201909-1041)情况的报送。成功利用此漏洞的攻击者,可以在目标系统远程执行恶意代码。泛微E-cology7.0、8.0、8.1、9.0等多个版本均受此漏洞影响。目前,泛微官方已经发布更新修复了该漏洞,请用户及时确认是否受到漏洞影响,尽快采取修补措施。

一、漏洞介绍

       泛微E-cology OA系统是一套兼具企业信息门户、知识管理、数据中心、工作流管理、人力资源管理、客户与合作伙伴管理、项目管理、财务管理、资产管理功能的协同商务平台。漏洞源于泛微e-cology OA系统的JAVA Beanshell接口可被未授权访问,攻击者调用该Beanshell接口,可构造特定的HTTP请求绕过泛微本身一些安全限制从而达成远程命令执行。

       通过对泛微E-cology OA系统在互联网中的IP地址进行分析,2019年全球共24615个用户联网使用该系统,主要用户分布在中国,共23094个,其中域名为gov的政府用户共102个。目前该漏洞poc已经在网络中流传,存在较大风险,建议用户及时修复。

二、危害影响

       成功利用此漏洞的攻击者,可以在目标系统远程执行恶意代码。受漏洞影响版本如下:

       E-cology 7.0

       E-cology 8.0

       E-cology 8.1

       E-cology 9.0(未测试,影响未知)

三、修复建议

       目前,泛微官方已经发布更新修复了该漏洞,请用户及时确认是否受到漏洞影响,尽快采取修补措施。泛微官方更新链接地址:

       https://www.weaver.com.cn/cs/securityDownload.asp

       本通报由知道创宇404实验室、杭州安恒信息技术股份有限公司、奇安信科技集团股份有限公司、北京长亭科技有限公司等CNNVD技术支撑单位提供支持。

       CNNVD将继续跟踪上述漏洞的相关情况,及时发布相关信息。如有需要,可与CNNVD联系。

       联系方式: cnnvd@itsec.gov.cn



漏洞预警快速查询