【漏洞预警】CNNVD 关于Exim 远程代码执行漏洞的通报

发布时间:2019-09-10   

       近日,国家信息安全漏洞库(CNNVD)收到关于Exim 远程代码执行漏洞(CNNVD-201909-249、CVE-2019-15846)情况的报送。攻击者利用该漏洞可以进行远程代码执行攻击。Exim 4.92.1及其以下版本均受漏洞影响。目前,Exim官方已发布了Exim 4.92.2版本修复该漏洞,建议用户及时确认是否受到漏洞影响,尽快采取修补措施。

一、 漏洞介绍

       Exim是一个运行于Unix系统中的开源消息传送代理(MTA),它主要负责邮件的路由、转发和投递。Exim可运行于绝大多数的类UNIX系统上,包括了Solaris、AIX、Linux等。

       漏洞源于Exim 4.92.1中的SMTP投递过程存在缓冲区溢出,在默认配置下, TLS协商期间,攻击者通过发送以反斜杠空{ '\\', '\0' }序列结尾的SNI来利用此漏洞,此时string_unprinting函数调用string_interpret_escape函数处理转义序列,由于string_interpret_escape函数中没有处理'\0'的情况,造成了越界读取。在其他配置中,可以使用精心构造的客户端TLS证书进行利用,攻击者可通过发送特殊构造的请求远程触发此漏洞。成功利用此漏洞的攻击者,可以获取root权限在系统上执行任意代码。

二、危害影响

       Exim在全球范围内被广泛使用,据统计,共有6492818个用户使用了Exim,其中国内用户32555个,攻击者可通过发送特殊构造的请求远程触发此漏洞,成功利用此漏洞的攻击者,可以获取root权限在系统上执行任意代码。Exim 4.92.1及其以下版本均受漏洞影响。

三、修复建议

       目前,Exim官方已发布了Exim 4.92.2版本修复该漏洞,建议用户及时确认是否受到漏洞影响,尽快采取修补措施。官方链接如下:

       https://ftp.exim.org/pub/exim/exim4/exim-4.92.2.tar.gz

       本通报由CNNVD技术支撑单位——奇安信科技集团股份有限公司、北京启明星辰信息安全技术有限公司提供支持。

       CNNVD将继续跟踪上述漏洞的相关情况,及时发布相关信息。如有需要,可与CNNVD联系。

       联系方式: cnnvd@itsec.gov.cn



漏洞预警快速查询

热点漏洞

更多