【漏洞预警】CNNVD 关于Oracle WebLogic wls9-async反序列化远程命令执行漏洞的通报

发布时间:2019-04-23   

       近日,国家信息安全漏洞库(CNNVD)收到Oracle WebLogic wls9-async反序列化远程命令执行漏洞(CNNVD-201904-961)情况的报送。攻击者可利用该漏洞在未授权的情况下发送攻击数据,实现远程代码执行。WebLogic 10.X、WebLogic 12.1.3等版本均受漏洞影响。目前, Oracle官方未发布漏洞补丁,但可以通过临时解决措施缓解漏洞造成的危害,建议用户及时确认是否受到漏洞影响,尽快采取修补措施。

一、漏洞介绍

       Oracle WebLogic Server是美国甲骨文(Oracle)公司开发的一款适用于云环境和传统环境的应用服务中间件,它提供了一个现代轻型开发平台,支持应用从开发到生产的整个生命周期管理,并简化了应用的部署和管理。

       部分版本WebLogic中默认包含的wls9_async_response包,为WebLogic Server提供异步通讯服务。由于该WAR包在反序列化处理输入信息时存在缺陷,攻击者可以发送精心构造的恶意 HTTP 请求,获得目标服务器的权限,在未授权的情况下远程执行命令。

二、危害影响

       攻击者可利用漏洞在未授权的情况下发送攻击数据,最终实现远程代码执行。该漏洞涉及了多个版本,具体受影响版本如下:

WebLogic 10.X

WebLogic 12.1.3

三、修复建议

       目前, Oracle官方未发布漏洞补丁,但可以通过临时解决措施缓解漏洞造成的危害,建议用户及时确认是否受到漏洞影响,尽快采取修补措施。

       通过访问策略控制禁止 /_async/* 路径的URL访问,此操作可能会造成业务系统无法正常使用,可通过白名单机制允许授权用户访问。

       建议使用WebLogic Server构建网站的信息系统运营者进行自查,发现存在漏洞后,按照临时解决方案及时进行修复。

       本通报由CNNVD技术支撑单位——启明星辰信息技术有限公司(积极防御实验室)、北京天融信网络安全技术有限公司、深信服科技股份有限公司、北京圣博润高新技术股份有限公司、网神信息技术(北京)股份有限公司、河南听潮盛世信息技术有限公司提供支持。

       CNNVD将继续跟踪上述漏洞的相关情况,及时发布相关信息。如有需要,可与CNNVD联系。

       联系方式: cnnvd@itsec.gov.cn




漏洞预警快速查询

热点漏洞

更多