漏洞名称: Linux kernel 缓冲区错误漏洞
CNNVD编号: CNNVD-201612-744
发布时间: 2016-12-29
更新时间: 2017-01-03
危害等级: 高危  高危
漏洞类型: 缓冲区溢出
威胁类型: 本地
CVE编号: CVE-2012-6704

Linux kernel是美国Linux基金会发布的操作系统Linux所使用的内核。

Linux kernel 3.4.99及之前的版本中的net/core/sock.c文件的‘sock_setsockopt’函数存在安全漏洞,该漏洞源于程序没有正确的处理‘sk_sndbuf’和‘sk_rcvbuf’的负值。本地攻击者可借助带有SO_SNDBUF或SO_RCVBUF选项的setsockopt系统调用利用该漏洞造成拒绝服务(内存损坏和系统崩溃)。

目前厂商已经发布了升级补丁以修复此安全问题,补丁获取链接:
        http://git.kernel.org/cgit/linux/kernel/git/torvalds/linux.git/commit/?id=82981930125abfd39d7c8378a9cfdf5e1be2002b

   
 

Linux Linux_kernel:3 ...