漏洞名称: Linux kernel 拒绝服务漏洞
CNNVD编号: CNNVD-201611-640
发布时间: 2016-11-29
更新时间: 2016-11-29
危害等级: 中危  中危
漏洞类型: 资源管理错误
威胁类型: 本地
CVE编号: CVE-2016-8650

Linux kernel是美国Linux基金会发布的操作系统Linux所使用的内核。NFSv4 implementation是其中的一个分布式文件系统协议。

Linux kernel 4.8.11及之前版本中的lib/mpi/mpi-pow.c文件的‘mpi_powm’函数存在安全漏洞,该漏洞源于程序没有正确为limb数据分配内存。本地攻击者可通过add_key系统调用利用该漏洞造成拒绝服务(栈内存损坏)。

目前厂商已经发布了升级补丁以修复此安全问题,补丁获取链接:
        http://git.kernel.org/cgit/linux/kernel/git/torvalds/linux.git/commit/?id=f5527fffff3f002b0a6b376163613b82f69de073

   
 

Linux Linux_kernel:4 ...