关于Linux 内核漏洞情况的通报
发布日期: 2016-12-09

近日,互联网上披露了关于Linux内核存在竞争条件漏洞(CNNVD-201612-097)的相关情况。2016年11月30日,The Linux Kernel Organization 已针对该漏洞发布升级版本。由于上述漏洞影响范围广,危害级别高,国家信息安全漏洞库(CNNVD)对此进行了跟踪分析,情况如下:
        一、漏洞简介
        Linux kernel是美国Linux基金会发布的操作系统Linux所使用的内核。
        Linux kernel 4.8.12及之前版本的net/packet/af_packet.c文件中存在竞争条件漏洞(CNNVD-201612-097,CVE-2016-8655)。本地攻击者可借助‘CAP_NET_RAW’权限更改套接字版本利用该漏洞获取特权,或造成拒绝服务(释放后重用)。
        二、漏洞危害
        1、攻击者只需要本地低权限,就能利用该漏洞导致拒绝服务(系统崩溃)或者以管理员权限执行任意代码。
        2、若部署在该服务器上的Web应用存在安全漏洞,当远程攻击者利用Web漏洞获取本地权限后,可利用该漏洞提升权限至超级管理员(root),从而完全控制服务器。
        三、修复措施
        目前,The Linux Kernel Organization已发布该漏洞的修复补丁,并且该漏洞细节及利用工具已在互联网上公开,请受影响用户尽快升级至最新版Linux Kernel以消除安全风险。官方链接如下:
        Linux Kernel git存储库:https://git.kernel.org/cgit/linux/kernel/git/torvalds/linux.git/commit/?id=84ac7260236a49c79eede91617700174c2c19b0c


        本报告由CNNVD技术支撑单位—北京知道创宇信息技术有限公司提供支持。
        CNNVD将继续跟踪上述漏洞的相关情况,及时发布相关信息。如有需要,可与CNNVD联系。
        联系方式: cnnvd@itsec.gov.cn